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Errore "Unable to Sign In. User account not found" dopo la configurazione di SAML su Tableau Server

Data pubblicazione: Apr 28, 2023
Descrizione
Dopo aver configurato Tableau per l'autenticazione SAML, gli utenti non sono in grado di accedere e si verifica il seguente errore: 

Unable to Sign In
User account not found (Impossibile accedere - Account utente non trovato)

 

Cause

Il valore username inviato dall'IdP non corrisponde al nome utente in Tableau Server o Tableau Cloud. 
Risoluzione
Assicurati che il valore username inviato a Tableau Server o Tableau Cloud dal provider di identità (IdP) corrisponda esattamente al nome utente in Tableau Server o Tableau Cloud.

Ad esempio, per l'utente seguente, il valore username inviato dall'IdP dovrà essere "test", non "test user" o "test@test.com".
 
Immagine inserita dall'utente

Se il valore username sul lato IdP non corrisponde al nome utente in Tableau Server o Tableau Cloud, valuta una delle opzioni seguenti per allineare i valori.

Opzione 1

Se un valore nell'IdP diverso da username corrisponde al nome utente in Tableau Server.

Ad esempio, se il nome visualizzato corrisponde al nome utente in Tableau Server, puoi effettuare una delle seguenti operazioni:

Per Tableau Server per Windows versioni 2018.2 e successive o per Tableau Server per Linux:

Imposta una regola di attributo sull'IdP in modo da inviare il valore del nome visualizzato come nome utente.
  • Utilizza TSM per indicare a Tableau Server di valutare il nome visualizzato come nome utente. Questa operazione può essere eseguita nell'interfaccia utente di TSM come descritto nel passaggio 5 delle impostazioni SAML in Configurare SAML a livello di server.
  • Può anche essere effettuata nella CLI di TSM, eseguendo il seguente comando da un prompt dei comandi aperto come amministratore:
tsm authentication saml map-asssertions --user-name displayname
Nota: Per questo comando viene applicata la distinzione tra maiuscole e minuscole, quindi assicurati di specificare il nome dell'attributo esattamente come viene visualizzato nell'IdP. Ad esempio, se l'attributo IdP è "DisplayName", utilizza DisplayName anziché displayname nel comando TSM.

Per Tableau Server per Windows versioni 2018.1 e precedenti:

Utilizza tabadmin per indicare a Tableau Server di valutare il nome visualizzato come nome utente:
  1. Apri il prompt dei comandi come amministratore
  2. Passa alla cartella bin di Tableau Server, disponibile per impostazione predefinita in C:\Program Files\Tableau\Tableau Server\<version>\bin, e immetti il comando seguente: 
    tabadmin set wgserver.saml.idpattribute.username displayname

    Nota: Per questo comando viene applicata la distinzione tra maiuscole e minuscole, quindi assicurati di specificare il nome dell'attributo esattamente come viene visualizzato nell'IdP. Ad esempio, se l'attributo IdP è "DisplayName", utilizza DisplayName anziché displayname nel comando tabadmin set.

Opzione 2

Se non è presente alcun valore sul lato IdP che corrisponde al nome utente in Tableau Server o Tableau Cloud oppure non è possibile apportare modifiche all'IdP.

  • Modifica i nomi utente in Tableau Server o Tableau Cloud in modo che corrispondano al valore inviato dall'IdP.
Risorse aggiuntive

Se sono presenti utenti in domini non predefiniti, il valore del nome utente per questi utenti deve includere il prefisso del dominio.
Numero articolo Knowledge

001498392

 
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