Loading

Lors de la connexion à Tableau Cloud à partir du composant Web Lightning Tableau Viz, l’erreur « verify.salesforce.com refused to connect » se produit si la méthode d’authentification de l’utilisateur est Tableau avec MFA

Date de publication: Apr 12, 2025
Description

Lors de la connexion à Tableau Cloud à partir du composant Web Lightning (LWC) Tableau Visualization, l’erreur suivante se produit si la méthode d’authentification de l’utilisateur est « Tableau avec MFA ».

« verify.salesforce.com refused to connect » 
Ou
« sso.online.tableau.com refused to connect. » se produit.

Image ajoutée par l'utilisateur

Cause

Lorsque l'authentification Salesforce est activée, les utilisateurs sont dirigés vers la page de connexion dans un cadre en ligne (iFrame). La Politique de sécurité des contenus (CSP) par défaut de Salesforce peut bloquer ces redirections dans les iframes pour des raisons de sécurité.

Résolution

Option 1

Utilisez le composant Web Lightning Tableau View au lieu du composant Web Lightning TableauVisualization (Viz). Ajoutez l'URL de confiance dans Salesforce et configurez l'authentification transparente. Pour plus d'informations, consultez Configuring Tableau Lightning Web Components and Seamless Authentication et Incorporation de vues Tableau dans les pages Lightning.

Option 2

Désactivez la méthode d’authentification Salesforce supplémentaire. Pour plus d'informations, consultez Authentification Salesforce.

Option 3

Connectez-vous à Tableau Cloud directement dans un autre onglet du même navigateur, puis actualisez et visualisez la page Salesforce.

Option 4

Changez le type d'authentification utilisateur de Tableau avec MFA vers des méthodes d'authentification unique (SSO), telles que l'authentification Salesforce ou SAML. Pour plus d'informations, consultez Set the User Authentication Type.

Numéro d’article de la base de connaissances

001498507

 
Chargement
Salesforce Help | Article