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Quando accedi a Tableau Cloud dal componente Web Lightning Tableau Viz, si verifica l'errore "verify.salesforce.com refused to connect" se il metodo di autenticazione utente è Tableau con MFA

Data pubblicazione: Apr 12, 2025
Descrizione

Quando accedi a Tableau Cloud dal componente Web Lightning (LWC) Tableau Visualization, si verifica l'errore seguente se il metodo di autenticazione utente è "Tableau con MFA".

"verify.salesforce.com refused to connect" 
Oppure
"sso.online.tableau.com refused to connect." occurs.

Immagine inserita dall'utente

Causa

Quando è abilitata l'autenticazione Salesforce, gli utenti vengono indirizzati alla pagina di accesso all'interno di un frame in linea (iFrame). Per motivi di sicurezza, i reindirizzamenti all'interno degli iframe possono essere bloccati dalla CSP (Content Security Policy) predefinita di Salesforce.

Risoluzione

Opzione 1

Utilizza l'LWC Vista Tableau, anziché il componente LWC Tableau Visualization(Viz). Aggiungi l'URL affidabile in Salesforce e imposta un'autenticazione senza soluzione di continuità. Per ulteriori informazioni, vedi Configurazione dei componenti Web Lightning e dell'autenticazione senza soluzione di continuità di Tableau e Incorporamento delle Viste Tableau nelle pagine Lightning.

Opzione 2

Disabilita il metodo di autenticazione Salesforce aggiuntivo. Per ulteriori informazioni, vedi Autenticazione Salesforce.

Opzione 3

Accedi a Tableau Cloud direttamente da una scheda separata dello stesso browser, quindi aggiorna e visualizza la pagina Salesforce.

Opzione 4

Modifica il tipo di autenticazione utente da Tableau con MFA a Single Sign-On (SSO), ad esempio Autenticazione Salesforce o SAML. Per ulteriori informazioni, vedi Impostare il tipo di autenticazione utente.

Numero articolo Knowledge

001498507

 
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