Loading

No se muestra la configuración o el recuento de licencias de Tableau Server después de cambiar la clave de USL y utilizar la activación sin conexión

Fecha de publicación: Sep 18, 2023
Descripción

Después de activar una nueva clave de licencia de suscripción actualizable (USL) sin conexión mediante el método de activación sin conexión, TSM muestra un error de coincidencia entre el recuento de licencias y la capacidad total del rol.  En Tableau Server, el recuento de roles nuevos no se muestra como se esperaba después de activar la clave de USL nueva sin conexión.

Como resultado, al agregar un usuario nuevo o intentar asignar un rol de sitio a un usuario existente, es posible que se produzca el siguiente error:

Setting site role for user <username> to '<siterole>' failed (Error al establecer el rol de sitio del usuario <username> para '<siterole>').

Este problema solo se produce cuando se reemplaza una clave de USL por una nueva que cambió una función adicional o la capacidad del rol del sitio, y se utiliza el método de activación sin conexión.
 

Cause

Debido a que el equipo se encuentra en modo sin conexión, Tableau Server no puede llamar al servidor de licencias para obtener de manera automática la licencia actualizada.  

La interfaz de usuario de TSM muestra y utiliza la clave de licencia USL anterior y no la que se activó recientemente sin conexión porque la fecha de finalización de la suscripción es la misma y solo cambió la configuración (capacidad o funcionalidades).
Solución
Para que Tableau Server en modo sin conexión refleje el cambio a la configuración correcta, se debe desactivar la clave de producto anterior y activar la nueva clave de USL.  Siga los pasos que se detallan a continuación para actualizar Tableau Server según el cambio a la nueva licencia USL:
  1. Busque el actual ID de activación sin conexión en el Portal de clientes.
  2. Detenga Tableau Server.
  3. Inicie la desactivación sin conexión de la clave activada actual en Server (el ID de activación sin conexión anterior).
    • Se generará un archivo de solicitud de devolución. El administrador de Tableau Server debe guardar este archivo y continuar.
  4. Inicie una activación sin conexión del actual ID de activación sin conexión.
    • Se generará un archivo de solicitud de activación. El administrador de Tableau Server debe guardar este archivo y continuar.
  5. Transfiera los archivos de solicitud de devolución y activación a la red de confianza.
  6. Vaya a https://www.tableau.com/es-es/support/activation en un navegador web e inicie ambas solicitudes en este orden:
    • Cargue el archivo de solicitud de devolución y descargue el archivo de respuesta. Guárdelo y continúe.
    • Cargue el archivo de solicitud de activación y descargue el archivo de respuesta. Guárdelo y continúe.
  7. Transfiera los archivos de solicitud de devolución y activación a la red que no es de confianza.
  8. Aplique el archivo de respuesta de devolución.
  9. Aplique el archivo de respuesta de activación.
  10. Inicie Tableau Server.
 
Recursos adicionales
Este problema no afecta a las claves de USL activadas mediante el método de activación en línea.

Activar Tableau Server sin conexión: añadir una licencia
 
Desactivar Tableau Server sin conexión

Para obtener más información sobre las claves de USL, consulte el artículo Conocer los modelos de licencia y las claves de producto de la Ayuda en línea de Tableau.
Número del artículo de conocimiento

001498522

 
Cargando
Salesforce Help | Article