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En el inicio de sesión SAML de Tableau Server se recibe el error "No se puede iniciar sesión: nombre de usuario o contraseña no válidos"

Fecha de publicación: Jan 6, 2023
Descripción

Al iniciar sesión en Tableau Server mediante SAML, después de la autenticación con el proveedor de identidad, aparece una página de error en Tableau Server en la que se lee "No se puede iniciar sesión" seguido de "Nombre de usuario o contraseña no válidos".

Además, la respuesta de autorización (authnresponse) del proveedor de identidad contiene lo siguiente:

<samlp:Status><samlp:StatusCode Value=\"urn:oasis:names:tc:SAML:2.0:status:Responder\"><samlp:StatusCode Value=\"urn:oasis:names:tc:SAML:2.0:status:RequestDenied\"/></samlp:StatusCode><samlp:StatusMessage>No tiene autorización para acceder a esta aplicación.</samlp:StatusMessage><samlp:StatusDetail><Cause>org.sourceid.saml20.domain.AuthorizationException: NO tiene autorización para acceder a esta aplicación.</Cause></samlp:StatusDetail></samlp:Status>

La respuesta de autorización se recoge en:

  1. Capturas de red, como Fiddler
  2. Utilidades de seguimiento de SAML, como Chrome SAML Tracer
  3. Para SAML en todo el servidor, los registros de VizPortal de Tableau Server cuando vizportal.log.level está configurado para depurar
  4. Para SAML específico del sitio, en los registros samlservice de Tableau Server

Cause

El usuario no tiene permisos para utilizar la aplicación de Tableau Server en el proveedor de identidad.
Solución
El proveedor de identidad debe asignar el usuario a la aplicación de Tableau Server. Para llevar a cabo esta acción, es necesario un administrador del proveedor de identidad.
Número del artículo de conocimiento

001498562

 
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