Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

Tableau Server の SAML ログイン時にエラー "サインインできません - ユーザー名またはパスワードが無効です" が発生した

公開日: Jan 6, 2023
説明

SAML を使用して Tableau Server にログインするとき、ID プロバイダーを使用した認証の後に、"Unable to Sign In" (サインインできません)、"Invalid username or password" (ユーザー名またはパスワードが無効です) というエラー ページが Tableau Server で表示されます。

さらに、ID プロバイダーからの authnresponse には次の情報が含まれています。

<samlp:Status><samlp:StatusCode Value=\"urn:oasis:names:tc:SAML:2.0:status:Responder\"><samlp:StatusCode Value=\"urn:oasis:names:tc:SAML:2.0:status:RequestDenied\"/></samlp:StatusCode><samlp:StatusMessage>You are NOT authorized to access this Application. (このアプリケーションにアクセスする権限がありません。)</samlp:StatusMessage><samlp:StatusDetail><Cause>org.sourceid.saml20.domain.AuthorizationException: You are NOT authorized to access this Application.</Cause></samlp:StatusDetail></samlp:Status>

authnresponse は次の方法で確認できます。

  1. Fiddler などのネットワーク キャプチャ
  2. Chrome SAML Tracer などの SAML トレース ユーティリティ
  3. サーバー全体 SAML の場合: vizportal.log.level が debug に設定されているときの Tableau Server vizportal ログ
  4. サイト固有 SAML の場合: Tableau Server samlservice ログ

Cause

ユーザーが ID プロバイダーで Tableau Server アプリケーションに対するパーミッションを付与されていません。
解決策
ID プロバイダーでユーザーを Tableau Server アプリケーションに割り当てる必要があります。このアクションには ID プロバイダーの管理者が必要です。
ナレッジ記事番号

001498562

 
読み込み中
Salesforce Help | Article