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Tableau Desktop で Tableau Server にサインインできない: ポップアップ Web ページがどこにもリダイレクトされない

公開日: Jan 19, 2023
説明

Tableau Desktop で Tableau Server にサインインできません。ポップアップ Web ページからリダイレクトされた URL では "このサイトに到達できません" と表示されますが、Web ブラウザーから Tableau Server へのサインインは正常です。
ユーザーが追加した画像

Cause

Tableau Server の nginx プロキシによってヘッダーが変更されるため、URL にアクセスできません。
解決策
Tableau Desktop からのサインイン時にブラウザーで適切な URL にリダイレクトするように、nginx プロキシ サーバーの設定を変更する必要があります。次の手順は、Fiddler を使用してトレース ログを収集し、問題を検証する方法を示します。 

Fiddler を使用して、Tableau Desktop マシン上でネットワーク トレースを収集します。Fiddler は HTTP トラフィックをキャプチャします。Fiddler は、400 または 500 エラーがあるかどうかを確認するのに便利です。Fiddler は、通信をブロックしているファイアウォールまたはプロキシを示すこともできます。
  1. 次のページから Fiddler をダウンロードしてインストールします: https://www.telerik.com/download/fiddler
  2. コンピューター上で開いているすべての Web ブラウザーとプログラム (チャット、メールなど) を終了します。
  3. [スタート] > [プログラム] > [Fiddler] をクリックします。
  4. HTTPS トラフィックを復号化します。[Tools (ツール)] > [Fiddler Options (Fiddler のオプション)] > [HTTPS] タブを選択し、[Decrypt HTTPS traffic (HTTP トラフィックを復号化)] にチェックを付け、証明書を受け入れて [OK] をクリックします。注: この手順はとても重要です。
  5. Tableau Desktop を使用して問題を再現します。
  6. Fiddler トレースの確認中、コード 302 の応答をクリックします。右側で [Inspector (インスペクター)] を選択し、[Request (要求)] と [Response (応答)] の両方について "Raw (未加工)" を選択します。次に示している画像のように、nginx プロキシ サーバーで URL が変更され、Tableau Desktop に応答が返されています。ユーザーが追加した画像
  7. この Fiddler トレースを保存して IT/セキュリティ チームに送ります。IT/セキュリティ チームと連携して、nginx プロキシ サーバーの URL フィルタリング ルールを修正します。
ナレッジ記事番号

001498617

 
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