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Tableau Cloud Embedded Views Blocked on Safari Due to Cross Site or Third-Party Cookies

Veröffentlichungsdatum: Apr 8, 2025
Beschreibung

When accessing Tableau Cloud embedded views, including when embedding views using Connected Apps, some users may encounter a login prompt for Tableau Cloud in their browser or certain browsers, particularly when using Safari browser on both desktop and mobile devices. 

Users may also be prompted to sign in to Tableau Cloud multiple times when navigating the site or when switching between multiple browser tabs. 

In the browser settings, third-party cookies are blocked and the option Prevent cross-site tracking in Safari browser settings is enabled.

Cause

Third party cookies are required for embedded content on Tableau Cloud, even when using Connected Apps. The Connected App product help pages note, For users to successfully authenticate when they access embedded content, browsers must be configured to allow third-party cookies.

Lösung

Change the browser setting to allow third-party cookies. The steps below may change slightly with changes or updates to the browser, please consult the browser documentation for information about how to change settings if these instructions do not match your browser options.

For Safari: Desktop

  1. In the Safari browser on Mac, choose Safari > Settings, then click Privacy.
  2. Uncheck “Prevent cross-site tracking.”

For Safari: iOS device

  1. In the iOS device, navigate to settings (Gear icon)
  2. Select Apps > Safari
  3. Under the Privacy & Security section, ensure "Prevent Cross-Site Tracking" is disabled
  4. Try to access Tableau Cloud via the browser app again to see if the issue still occurs.
Nummer des Knowledge-Artikels

001498716

 
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