Loading

Frag die Daten" befindet sich in einem Fehlerzustand

Veröffentlichungsdatum: Feb 16, 2023
Beschreibung

"Frag die Daten" befindet sich in einem Fehlerzustand.

Cause

  • Umgebungskonflikt oder falsche Anzahl von Prozessen
  • Server-Geheimnisse können beschädigt werden, wenn die internen Tokens nicht erfolgreich neu generiert wurden.
Lösung

Option 1

Zur Behebung des Problems aufgrund von beschädigten Servergeheimnissen durch einen früheren Versuch, interne Token zu regenerieren, führen Sie den folgenden Befehl erneut aus:
tsm security regenerate-internal-tokens
 

Option 2

Wie in der Tableau Online-Hilfe besprochen, wird empfohlen, eine insgesamt ungerade Anzahl an Elastic Server-Prozessen oder Index- und Suchserverprozessen zu nutzen.

Führen Sie auf dem Cluster die folgenden Schritte durch:

  1. Halten Sie Tableau Server an und führen Sie dann die Schritte 2 bis 4 auf jedem Knoten durch.
  2. Navigieren Sie auf jedem Knoten zu "C:\ProgramData\Tableau\Tableau Server\data\tabsvc\indexandsearchserver\0\nodes\0\"
  3. Zippen Sie den Inhalt dieses Ordners (wählen Sie die darin enthaltenen beiden Ordner "_state" und "indices" aus und zippen Sie sie) als "_state<Knotennummer hier angeben>".zip
  4. Lassen Sie die zip-Datei im Ordner "nodes\0\" und löschen Sie dann die Ordner "_state" und "indices".
  5. Entfernen Sie in der TSM-Benutzeroberfläche "indexandsearchserver" von den anderen Knoten, so dass der Prozess nur noch auf dem Hauptknoten vorhanden ist.
  6. Wenden Sie ausstehende Änderungen an.
  7. Starten Sie Tableau Server.
Wenn "Frag die Daten" wieder auf dem primären Knoten hochkommt, können Sie neue Index- und Suchserver-Prozesse auf die anderen Knoten im Cluster anwenden. Beachten Sie dabei jedoch, dass als Gesamtanzahl laufender Prozesse auf Elastic Server oder Index- und Suchserver eine ungerade Zahl empfohlen wird.



 
Zusätzliche Ressourcen
Um zu ermitteln, ob Option 1 erforderlich ist, werden die folgenden Informationen im Elasticsearch- und Ask Data-Protokollsatz in einer Schleife gezeigt:

2020-07-13 17:00:48.630 +0800 96666 main : INFO com.tableausoftware.nlp.NLPApp - Executing command with args [[getSecret]]
2020-07-13 17:00:49.429 +0800 96666 main : INFO com.tableausoftware.nlp.NLPApp - OK
2020-07-13 17:00:50.717 +0800 96692 main : INFO com.tableausoftware.nlp.NLPApp - Executing command with args [[getResponseSecret]]
2020-07-13 17:00:51.576 +0800 96692 main : INFO com.tableausoftware.nlp.NLPApp - OK
2020-07-13 17:00:52.681 +0800 96832 main : INFO com.tableausoftware.nlp.NLPApp - Executing command with args [[getElasticPassword]]
2020-07-13 17:00:53.310 +0800 96832 main : INFO com.tableausoftware.nlp.NLPApp - OK

[2020-07-13T17:00:53,500][WARN ][c.f.s.a.BackendRegistry ] Authentication finally failed for admin (Authentifizierung für Administrator fehlgeschlagen)
 
Nummer des Knowledge-Artikels

001534317

 
Laden
Salesforce Help | Article