Loading

Datenträgerverwendung und Backup-Größe erhöht sich mit größerem Extraktordner in Tableau Server 2023.1.2, 2022.3.6, 2022.1.14

Veröffentlichungsdatum: Jan 2, 2024
Beschreibung
Der Tableau Server-Ordner C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract wird täglich größer und führt zu höherer Festplattennutzung und Sicherungsgröße.

Cause

Bei Hintergrundprozesskomponenten kommt es manchmal zu einer Zeitüberschreitung, wenn versucht wird, Listen von nicht mehr benötigten Ordner-IDs abzurufen, die aus den Dateispeicherprozessen gelöscht werden können.

Weitere Informationen finden Sie auf der Salesforce-Website für bekannte Probleme unter der ID W-13476908, wo die Lösung eingesetzt wurde.
Lösung

Option 1

Aktualisieren Sie Tableau Server auf eine der folgenden Versionen, und prüfen Sie das bekannte Salesforce-Problem W-13476908:

  • 2021.3.25+
  • 2021.4.20+
  • 2022.1.16+
  • 2022.3.8+
  • 2023.1.4+

Option 2

Nutzen Sie die Lösung von Option 2 (Konfigurieren des Dateispeicher-Timeout-Werts für die Verbindung) im folgenden Knowledgebase-Artikel:

Tableau Server-Sicherungen schlagen beim Überprüfen des Festplattenplatzes in 2022.3.6 und 2023.1 und höher fehl

Details:

Führen Sie in einer administrativen Eingabeaufforderung auf dem Controller-Knoten die folgende Konfigurationsänderung durch:
 
tsm configuration set -k filestore.client.sockettimeoutms -v 0
tsm pending-changes apply (Neustart erforderlich)
 

Option 3

Wenn möglich und als vorübergehende Maßnahme, bis eine der oben genannten Optionen umgesetzt werden kann, nutzen Sie Option 1 aus dem folgenden Knowledgebase-Artikel: 

Details:

  • Löschen Sie manuell die Dateien dataengine\extract\##\{FOLDERID}_TDFSTRNSFR\*.hyper, die seit dem letzten Aktualisierungsdatum älter als 24 Stunden sind.
  • HINWEIS: Tableau Server kann ausgeführt werden, während diese Dateien gelöscht werden.
  • Selbst wenn in den Pfaden keine .hyper-Dateien in dieser Form vorhanden sind, kann Tableau Server dennoch durch das Problem beeinträchtigt sein. Löschen Sie keine *.hyper-Dateien in anderen Unterverzeichnissen des Extraktordners, da dies verwaiste Datensätze im Tableau Server Repository erzeugen würde.
Zusätzliche Ressourcen

Identifizierung einer Übereinstimmung für dieses Problem


1. Stellen Sie sicher, dass die Tableau Server-Version der Liste der betroffenen Versionen im Abschnitt "Umgebung" oben entspricht.

2. Überprüfen Sie in C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract (Standardinstallationspfad), ob der Ordner größer als erwartet ist und ältere Dateien nicht geerntet werden.

3. Untersuchen Sie die Protokolle der Hintergrundprozesskomponenten, deren Dateinamen mit dem Wort "backgrounder" beginnen (z. B. backgrounder_node1-0.log), und suchen Sie nach "Method:getFolderIds to File Store on host".  Falls gefunden, sehen die Zeilen etwa so aus: "ERROR com.tableausoftware.tdfs.client.FileStoreService - Method:getFolderIds to File Store on host:<hostname>:<port> failed" (FEHLER: com.tableausoftware.tdfs.client.FileStoreService - Method:getFolderIds zu Dateispeicher auf Host:<hostname>:<port> fehlgeschlagen). Dabei ist <hostname> der Host, der einen Dateispeicherprozess enthält, und <port> ist der "worker<node>.filestore.port", der dem Dateispeicher zugewiesen ist.  Das Vorhandensein solcher Zeilen ist ein starker Indikator dafür, dass der Tableau Server durch das oben beschriebene Problem betroffen ist.
Nummer des Knowledge-Artikels

001534347

 
Laden
Salesforce Help | Article