Loading

El uso del disco y el tamaño de la copia de seguridad aumentan a medida que la carpeta de extracciones crece en Tableau Server 2023.1.2, 2022.3.6, 2022.1.14

Fecha de publicación: Jan 2, 2024
Descripción
La carpeta de Tableau Server C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract aumenta a diario, lo que provoca que el uso del disco y el tamaño de la copia de seguridad incrementen

Cause

A veces, los procesos del procesador en segundo plano se quedan sin tiempo de espera al intentar recuperar listas de ID de carpetas que ya no se necesitan y pueden eliminarse de los procesos del almacén de archivos.

Puede encontrar más información en el sitio web de problemas conocidos de Salesforce con el ID W-13476908 donde se ha implementado la solución.
Solución

Opción 1

Actualice Tableau Server a una de las siguientes versiones y revise el problema conocido de Salesforce W-13476908:

  • 2021.3.25+
  • 2021.4.20+
  • 2022.1.16+
  • 2022.3.8+
  • 2023.1.4+

Opción 2

Utilice la solución de la opción 2 (Configure el valor de tiempo de espera de conexión del almacén de archivos) del siguiente artículo de la base de conocimientos:

Las copias de seguridad de Tableau Server fallan al verificar el espacio en disco en 2022.3.6 y 2023.1+

Details:

Dentro de un símbolo del sistema administrativo en el nodo del controlador, aplique el siguiente cambio de configuración:
 
tsm configuration set -k filestore.client.sockettimeoutms -v 0
tsm pending-changes apply (requires a restart)
 

Opción 3

Donde sea factible y como medida temporal hasta que una de las opciones anteriores pueda implementarse, utilice la solución de la opción 1 del siguiente artículo de la base de conocimientos: 

Details:

  • Elimine de forma manual los archivos del directorio dataengine\extract\##\{FOLDERID}_TDFSTRNSFR\*.hyper que se hayan creado hace más de 24 horas desde la última actualización.
  • NOTA: Tableau Server se puede ejecutar mientras se eliminan estos archivos.
  • Aunque no haya archivos .hyper en rutas de este formulario, es posible que Tableau Server siga afectado por este problema. No elimine los archivos *.hyper en otros subdirectorios de la carpeta de extracción; esto hará que se creen registros huérfanos en el repositorio de Tableau Server.
Recursos adicionales

Identificación de una coincidencia para este problema


1. Confirme que la versión de Tableau Server coincide con la lista de versiones afectadas en la sección Entorno anterior

2. Revise C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract  (ruta de instalación predeterminada) y compruebe si el tamaño de la carpeta supera las expectativas, y que no se están recogiendo archivos más antiguos.

3. Examine los registros del procesador en segundo plano cuyos nombres de archivos empiezan por "backgrounder" (como backgrounder_node1-0.log) y busque "Method:getFolderIds to File Store on host".  En caso de que lo encuentre, será algo parecido a esto "ERROR com.tableausoftware.tdfs.client.FileStoreService - Method:getFolderIds to File Store on host:<hostname>:<port> failed" donde <host> es el nombre de host que contiene un proceso del almacén de archivos, y <port> es el <node>.filestore.port del trabajador asignado al almacén de archivos.  La presencia de estas líneas es un claro indicador de que Tableau Server está afectado por el problema que se ha descrito anteriormente.
Número del artículo de conocimiento

001534347

 
Cargando
Salesforce Help | Article