Loading
Salesforce から送信されるメールは、承認済ドメインからのみとなります続きを読む

Tableau Server 2023.1.2、2022.3.6、2022.1.14 で抽出フォルダーの増大に伴ってディスク使用量とバックアップ サイズが増加する

公開日: Jan 2, 2024
説明
Tableau Server C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract フォルダーが絶えず拡大し、ディスク使用量とバックアップ サイズが増加します

Cause

必要なくなったため、ファイル ストア プロセスから削除できる folderID のリストを取得しようとして、バックグラウンダー プロセスがタイムアウトすることがあります。

詳細については、Salesforce の既知の問題 Web サイトで、ID W-13476908 を参照してください。そこでソリューションが展開されています。
解決策

オプション 1

Tableau Server を次のいずれかのバージョンにアップグレードし、Salesforce の既知の問題 W-13476908 を確認してください。

  • 2021.3.25 以上
  • 2021.4.20 以上
  • 2022.1.16 以上
  • 2022.3.8 以上
  • 2023.1.4 以上

オプション 2

次のナレッジ ベース記事から、解決策のオプション 2 (ファイルストア接続タイムアウト値の構成) を利用します。

2022.3.6 および 2023.1 以降で、Tableau Server のバックアップがディスク空き容量を確認する段階で失敗する

Details: (詳細:)

コントローラ ノードの管理者権限コマンド プロンプト内で、次の構成変更を適用します。
 
tsm configuration set -k filestore.client.sockettimeoutms -v 0
tsm pending-changes apply (再起動が必要)
 

オプション 3

実現可能であれば、上記のいずれかのオプションを実装できるまでの一時的な手段として、次のナレッジ ベース記事から、解決策のオプション 1を利用します。 

Details: (詳細:)

  • 最終更新日から 24 時間以上経過した dataengine\extract\##\{FOLDERID}_TDFSTRNSFR\*.hyper ファイルを手動で削除します。
  • 注: Tableau Server の実行中にこれらのファイルを削除できます。
  • この形式のパスに .hyper ファイルが含まれていない場合でも Tableau Server はこの問題に影響を受ける可能性があります。抽出フォルダーの他のサブディレクトリ内の *.hyper ファイルを削除しないでください。これにより、Tableau Server リポジトリ内に孤立したレコードが作成されます。
その他のリソース

この問題に該当するかの確認


1. Tableau Server バージョンが上記の「環境」セクションの影響を受けるバージョンの一覧と一致することを確認します。

2. C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract (既定のインストール パス) を確認し、フォルダー サイズが予想を超えていて、古いファイルが取り除かれていないことを確認します。

3. ファイル名が "backgrounder" の語で始まるバックグラウンダー ログ (backgrounder_node1-0.log など) を調べて、"Method:getFolderIds to File Store on host" を検索します。  見つかった場合、この行は "ERROR com.tableausoftware.tdfs.client.FileStoreService - Method:getFolderIds to File Store on host:<hostname>:<port> failed" に似ており、ここで <host> はファイル ストア プロセスを格納するホスト名で、<port> はファイル ストアに割り当てられた worker<node>.filestore.port です。  そのようなファイルの存在は、Tableau Server が上記の問題に影響を受けていることの強力な指標です。
ナレッジ記事番号

001534347

 
読み込み中
Salesforce Help | Article