Loading

Fehler "Login timeout expired" (Anmeldungstimeout abgelaufen) beim Aktualisieren des Extrakts mit Bridge

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung

Beim Versuch, einen veröffentlichten Extrakt, der Tableau Bridge verwendet, nach der Aktualisierung auf die neueste Tableau Bridge-Version zu aktualisieren, kann der folgende Fehler auftreten:

Connection Failure (status code = 3000. There was an unknown connection error to the database. The error message below has additional information, but you might need to ask the database administrator to review the database logs. Kerberos RunAs authentication is not enabled on Linux [Microsoft][ODBC Driver 17 for SQL Server]TCP Provider: Error code 0x2AF9 [Microsoft][ODBC Driver 17 for SQL Server]Login timeout expired [Microsoft][ODBC Driver 17 for SQL Server]A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online. Unable to connect to the Microsoft SQL Server server '<server name>'. Check that the server is running and that you have access privileges to the requested database.) (Verbindungsfehler (Statuscode = 3000. Es ist ein unbekannter Verbindungsfehler zur Datenbank aufgetreten. Die folgende Fehlermeldung enthält zusätzliche Informationen, aber möglicherweise müssen Sie den Datenbankadministrator bitten, die Datenbankprotokolle zu überprüfen. Kerberos RunAs-Authentifizierung ist unter Linux nicht aktiviert [Microsoft][ODBC Driver 17 for SQL Server]TCP Provider: Fehlercode 0x2AF9 [Microsoft][ODBC Driver 17 for SQL Server]Zeitüberschreitung bei Anmeldung [Microsoft][ODBC Driver 17 for SQL Server]Ein netzwerkbezogener oder instanzspezifischer Fehler ist beim Aufbau einer Verbindung zu SQL Server aufgetreten. Der Server wurde nicht gefunden oder ist nicht erreichbar. Überprüfen Sie, ob der Instanzname korrekt ist und ob SQL Server so konfiguriert ist, dass Remoteverbindungen zugelassen werden. Weitere Informationen finden Sie in SQL Server Books Online. Es konnte keine Verbindung zum Microsoft SQL Server Server '<Servername>' hergestellt werden. Überprüfen Sie, ob der Server ausgeführt wird und ob Sie Zugriffsrechte für die angeforderte Datenbank haben.)

Cause

Der Extraktaktualisierungsauftrag wurde nicht an den Bridge-Client gesendet.
Lösung
Veröffentlichen Sie die betroffene Datenquelle neu:
  1. Öffnen Sie eine Tableau-Arbeitsmappe, die die veröffentlichte Datenquelle verwendet. Alternativ können Sie eine neue Arbeitsmappe öffnen und dann eine Verbindung zu einer veröffentlichten Datenquelle herstellen, indem Sie die Schritte unter Verbindung aus Tableau Desktop ausführen.
  2. Erstellen Sie eine lokale Kopie der Datenquelle: Klicken Sie mit der rechten Maustaste auf die veröffentlichte Datenquelle im Datenbereich, wählen Sie "Lokale Kopie erstellen" aus und speichern Sie die .tdsx-Datei auf Ihrem Computer.
  3. Veröffentlichen Sie die lokale Kopie der Datenquelle erneut und vergewissern Sie sich, dass die erforderlichen Anmeldeinformationen enthalten sind. Weitere Informationen finden Sie unter Veröffentlichen einer Datenquelle.  
Nummer des Knowledge-Artikels

001534466

 
Laden
Salesforce Help | Article