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Error code 0x2AF9 when refreshing MS SQL Server extract with Tableau Bridge

Publish Date: Apr 13, 2024
Description

When attempting to refresh a published extract that via Tableau Bridge, the following error may occur:

[Microsoft][ODBC Driver 17 for SQL Server]TCP Provider: Error code 0x2AF9
[Microsoft][ODBC Driver 17 for SQL Server]Login timeout expired
[Microsoft][ODBC Driver 17 for SQL Server]A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online. Unable to connect to the Microsoft SQL Server server '
<server name>'. Check that the server is running and that you have access privileges to the requested database.)

Cause

The extract refresh job was not sent to the Bridge client.
Resolution
Republish the affected data source:
  1. Open a Tableau workbook that uses the published data source. Alternatively, you can open a new workbook and then connect to a published data source using the steps in Connect from Tableau Desktop.
  2. Create a local copy of the data source: right-click the published data source in the Data pane, and then select Create Local Copy, and save the .tdsx file to a location on your computer.
  3. Republish the local copy of the data source, ensuring that the required credentials are included. For more information, see Publish a Data Source.  
Knowledge Article Number

001534466

 
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Salesforce Help | Article