Loading

Error "Login timeout expired" al actualizar una extracción con Bridge

Fecha de publicación: Dec 9, 2022
Descripción

Al intentar actualizar un extracto publicado que utiliza Tableau Bridge, luego de actualizar a la versión más reciente de Tableau Bridge, puede producirse el siguiente error:

Connection Failure (status code = 3000. Se ha producido un error de conexión desconocido en la base de datos. The error message below has additional information, but you might need to ask the database administrator to review the database logs. (Se produjo un error de conexión desconocido en la base de datos. El siguiente mensaje de error contiene información adicional, pero es posible que deba pedirle al administrador de la base de datos que revise los registros de base de datos). Kerberos RunAs authentication is not enabled on Linux [Microsoft][ODBC Driver 17 for SQL Server]TCP Provider: Error code 0x2AF9 [Microsoft][ODBC Driver 17 for SQL Server]Login timeout expired [Microsoft][ODBC Driver 17 for SQL Server]A network-related or instance-specific error has occbrred while establishing a connection to SQL Server.(La autenticación de Kerberos RunAs no está habilitada en Linux [Microsoft][Controlador ODBC 17 para SQL Server] Proveedor TCP: código de error 0x2AF9 [Microsoft][Controlador ODBC 17 para SQL Server] Tiempo de espera de la sesión caducado0x2AF9 [Microsoft][Controlador ODBC 17 para SQL Server] Se produjo un error relacionado con la red o específico de la instancia mientras se establecía una conexión con SQL Server). Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see SQL Server Books Online. Unable to connect to the Microsoft SQL Server'<server name>'. (No es posible conectarse al servidor de Microsoft SQL Server <nombre de servidor>). Check that the server is running and that you have access privileges to the requested database. (Compruebe que el servidor esté en ejecución y que el usuario tenga privilegios de acceso a la base de datos solicitada).

Cause

El trabajo de actualización de la extracción no se envió al cliente de Bridge.
Solución
Volver a publicar la fuente de datos afectada:
  1. Abra un libro de trabajo de Tableau que utilice la fuente de datos publicada. De forma alternativa, puede abrir un nuevo libro de trabajo y, luego, conectarse a una fuente de datos publicada; para ello, siga los pasos en Conectar desde Tableau Desktop.
  2. Cree una copia local de la fuente de datos: haga clic con el botón derecho en la fuente de datos publicada en el panel Datos y, a continuación, seleccione Crear copia local y guarde el archivo .tdsx en una ubicación en su equipo.
  3. Vuelva a publicar la copia local de la fuente de datos para garantizar que las credenciales requeridas estén incluidas. Para obtener más información, consulte Publicar una fuente de datos.  
Número del artículo de conocimiento

001534466

 
Cargando
Salesforce Help | Article