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Error "Tableau failed to create an extract" upon connecting to Salesforce

Data pubblicazione: Feb 23, 2026
Descrizione

Upon connecting to Salesforce data source from Tableau Deskop, drag a table to the canvas, and if the table has more than 1 million rows, after 10-12 minutes query, the error occurs: "Tableau failed to create an extract" 
 

Cause

This is due to the Salesforce Output Connector Limitation.

This is a known limitation related to the size and complexity of the Salesforce dataset being extracted. Large datasets or complex queries can cause timeouts or internal server errors during extract creation in Tableau.

Maximum data written to Tableau Online

1 GB, or 1 million rows of data per run of a recipe per output connector

1 GB, or 1 million rows per rolling 24-hour period

This is explained in the following article: https://help.salesforce.com/s/articleView?id=sf.bi_limits.htm&type=5

Risoluzione

1.  Reduce the Salesforce table dataset. Limit the number of records or fields you are extracting by applying filters or selecting fewer columns in the Tableau data source. This reduces the load and complexity of the extract.  

2. Export to CSV file or use Data Loader.

 If reducing the dataset is not feasible, export the required Salesforce data to a CSV file and then import that CSV into Tableau for analysis. 

https://developer.salesforce.com/tools/data-loader

https://help.salesforce.com/s/articleView?id=analytics.reports_export.htm&type=5

https://developer.salesforce.com/docs/atlas.en-us.dataLoader.meta/dataLoader/exporting_data.htm

 

 

Numero articolo Knowledge

001534522

 
Caricamento
Salesforce Help | Article