Loading

Se produjo un error “Licensing Service Unavailable” (Servicio de licencias no disponible) al activar Tableau Server Online a través de un servidor proxy de reenvío sin ATR habilitado

Fecha de publicación: Sep 29, 2023
Descripción

Cuando se activa Tableau Server en línea sin habilitar ATR mediante un servidor proxy de reenvío, puede que se produzca el siguiente error:

Servicio de licencia no disponible

Además, en los registros puede aparecer el siguiente error:

Tableau could not connect to the licensing server or FlexNet Operations Server. Verify the product key is correct and the primary or online licensing server can be accessed by ports 27000-27009. (Tableau no pudo conectarse con el servidor de licencias ni con el de operaciones de FlexNet. Compruebe que la clave del producto es correcta y que se puede acceder al servidor de licencias principal o en línea mediante los puertos 27 000- 27 009).

Cause

Para acceder a la información de claves de producto y, posteriormente, configurarla para la instalación de Tableau Server, el Controlador administrativo y el Servicio de activación de Tableau Server se deben ejecutar en la cuenta de ejecutar como servicio para pasar por el servidor proxy configurado. 

Debido a que el comportamiento cambió en las versiones más recientes (vea el entorno), también se debe ajustar el Servicio de activación cuando se utiliza un servidor proxy.
Solución
Luego de realizar el paso 2 como se lo describe en la Ayuda en línea de Tableau, Configure las operaciones clave de producto con el servidor proxy de reenvío, realice también lo siguiente para ajustar el Servicio de activación antes de avanzar al paso 3 en la ayuda en línea.  
  1. Haga clic derecho en Tableau Server Activation Service (Servicio de activación de Tableau Server) y, luego, haga clic en Properties (Propiedades). En la página Properties (Propiedades) del Servicio de activación de Tableau Server, seleccione la ficha Log On (Iniciar sesión).
  2. En la ficha Log On (Iniciar sesión), cambie Local System account (Cuenta del sistema local) por su cuenta de ejecutar como servicio. Ingrese la contraseña y haga clic en OK (Aceptar).
  3. En la consola de administración de Microsoft Services (Local) [Servicios (Local)], haga clic derecho en Tableau Server Activation Service (Servicio de activación de Tableau Server) y haga clic en Restart (Reiniciar).

Luego de completar la operación clave del producto, también debe cambiar la cuenta de inicio de sesión del Servicio de activación de Tableau Server a la cuenta del sistema local.

Como resultado, realice los siguientes pasos luego de completar el paso 4 como se describe en la ayuda en línea anterior.
  1. Haga clic derecho en Tableau Server Activation Service (Servicio de activación de Tableau Server) y, luego, haga clic en Properties (Propiedades). En la página Properties (Propiedades) del Servicio de activación de Tableau Server, seleccione la ficha Log On (Iniciar sesión).
  2. En la ficha Log On (Iniciar sesión), seleccione Local System account (Cuenta del sistema local) y haga clic en OK (Aceptar).
  3. En la consola de administración de Microsoft Services (Local) [Servicios (Local)], haga clic derecho en Tableau Server Activation Service (Servicio de activación de Tableau Server) y haga clic en Restart (Reiniciar).
Tenga en cuenta que la ayuda en línea de Tableau se actualizará en un futuro cercano para que incluya los pasos en este artículo.
Recursos adicionales
Configurar operaciones de claves de producto con un Proxy de reenvío

En las siguientes versiones de Tableau Server, el Servicio de activación se instala incluso cuando no se utiliza el método de activación de ATR; dicho comportamiento no sucedía con las versiones anteriores:
  • Tableau Server 2023.1.3 o versiones posteriores
  • Tableau Server 2022.3.7 o versiones posteriores
  • Tableau Server 2022.1.15 o versiones posteriores
Todas las solicitudes de licencia pasan por el Servicio de activación, excepto LBLM, y el Servicio de activación no será el único servicio que se puede comunicar con el almacenamiento de confianza de Flexera utilizado en las activaciones heredadas sin ATR.
Número del artículo de conocimiento

001534558

 
Cargando
Salesforce Help | Article