Loading

ATR-Server-Aktivierungsfehler "The server encountered an unexpected error processing the request." (Der Server ist bei der Verarbeitung der Anfrage auf einen unerwarteten Fehler gestoßen.)

Veröffentlichungsdatum: Dec 9, 2022
Beschreibung

Ein Server-Fehler tritt in der TSM Web-Benutzeroberfläche oder der TSM-Befehlszeile auf, wenn Tableau Server mit dem Authorization-To-Run (ATR)-Dienst unter Windows aktiviert wird.

Server Error (Serverfehler)
The server encountered an unexpected error processing the request. Look at the server logs for more information. (Der Server hat bei der Verarbeitung der Anfrage einen unerwarteten Fehler entdeckt. Weitere Informationen finden Sie in den Serverprotokollen.)


Wenn Sie stattdessen "tsm licenses activate --license-key <Produktschlüssel>" ausführen, wird in tsm.log der folgende Fehler angezeigt:

ERROR com.tableausoftware.tabadmin.TSMErrorHandler - An error occurred: 500000, Internal Server Error (Ein Fehler ist aufgetreten: 500000, Interner Serverfehler)
ERROR com.tableausoftware.tabadmin.cli.Console - Internal Server Error: The server encountered an unexpected error processing the request. Look at the server logs for more information. (Der Server hat bei der Verarbeitung der Anfrage einen unerwarteten Fehler entdeckt. Weitere Informationen finden Sie in den Serverprotokollen.)

 

Cause

Es gibt mehrere Szenarien, die diesen Fehler verursachen können:
  • Um auf die Produktschlüsselinformationen für die Tableau Server-Installation zuzugreifen und diese zu konfigurieren, muss der Windows-Dienst Tableau Server Administrative Controller unter dem "Als Dienst ausführen"-Konto ausgeführt werden.
  • Ein ungültiger Schlüssel wurde eingegeben, der einen Tippfehler enthält oder ein Desktop-Schlüssel ist, der mit "TC" beginnt.
  • Der Schlüssel ist maximal aktiviert.
Lösung

Option 1 

Überprüfen Sie das Tableau-Kundenportal und stellen Sie sicher, dass der eingegebene Lizenzschlüssel keinen Tippfehler enthält.  Häufige Tippfehler sind 0 und O, S und 5 sowie B und 8.  Der Lizenzschlüssel sollte mit den Buchstaben "TS" und nicht mit "TC" beginnen.

Option 2

Wenn das Konto Als Benutzer ausführen auf das standardmäßige Konto NT AUTHORITY\NetworkService eingestellt ist, ersetzen Sie es durch ein Domänenkonto und aktivieren oder deaktivieren Sie dann die Tableau-Produktschlüssel. Weitere Informationen finden Sie unter Konfigurieren von Produktschlüsselvorgängen mit einem Forward-Proxy.

Wenn ein Domänenkonto für Als Benutzer ausführen konfiguriert wurde, stellen Sie sicher, dass das Domänenkonto mit einem Forward-Proxy authentifiziert werden kann. Ändern Sie das Konto, falls erforderlich. Weitere Informationen finden Sie unter Verändern des Kontos "Als Dienst ausführen".

Option 3

Um eine maximale Aktivierung zu erreichen, deaktivieren Sie die Lizenzen auf einer Installation, die über die in unserer EULA angegebene zulässige Kapazität hinausgeht.

 

 

 

Zusätzliche Ressourcen
Im Protokoll wird möglicherweise die folgende Meldung aufgezeichnet.

Beispiel:
ziplogs\tabadmincontroller_0.20213.21.1112.143413223401664649809205\logs\tabadmincontroller_node1-0.log
2021-12-13 17:44:42.905 +0900  qtp1152429864-1433 : INFO  com.tableausoftware.tabadmin.webapp.impl.ProductKeyService - Activating license
2021-12-13 17:44:42.905 +0900  qtp1152429864-1433 : DEBUG com.tableausoftware.domain.licensing.InitializeNativeThreadSupplier - Initializing verifier foreground thread.
...
2021-12-13 17:45:33.578 +0900  qtp1152429864-1433 : ERROR com.tableausoftware.tabadmin.webapp.GlobalExceptionHandler - TableauException
com.tableausoftware.license.dll.TableauException: Operation timed out.


ziplogs\tabadmincontroller_0.20213.21.1112.143413223401664649809205\logs\nativeapi_tabadmincontroller_node1-0_2021_12_13_00_00_00.txt
{"ts":"2021-12-13T17:44:42.920","pid":10872,"tid":"3788","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"InitializeForegroundThread: 6de76dec5c828a40"}
{"ts":"2021-12-13T17:44:42.920","pid":10872,"tid":"3788","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"BEGIN Verifier::Activate for SerialNumber TSXX-XXXX-XXXX-XXXX-XXXX"}
...
{"ts":"2021-12-13T17:45:33.578","pid":10872,"tid":"3010","sev":"warn","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"Request for 'https://atr.licensing.tableau.com:443/server/getAtrForServer' failed."}

 
Weitere Informationen finden Sie unter:
Nummer des Knowledge-Artikels

001534723

 
Laden
Salesforce Help | Article