Loading

Error de activación del servidor de ATR "The server encountered an unexpected error processing the request"

Fecha de publicación: Dec 9, 2022
Descripción

Se muestra un error del servidor en la interfaz de usuario web de TSM o la línea de comandados de TSM al activar Tableau Server con el servicio Authorization-To-Run (ATR):

Error de servidor
The server encountered an unexpected error processing the request. Look at the server logs for more information. (El servidor ha encontrado un error inesperado al procesar la solicitud. Consulte los registros del servidor para obtener más información).


En cambio, después de ejecutar "tsm licenses activate --license-key <clave de producto>", se indica el siguiente error en tsm.log:

ERROR com.tableausoftware.tabadmin.TSMErrorHandler - Se produjo un error: 500000, Error de servidor interno
ERROR com.tableausoftware.tabadmin.cli.Console - Error de servidor interno: El servidor detectó un error inesperado al procesar la solicitud. Look at the server logs for more information. (El servidor ha encontrado un error inesperado al procesar la solicitud. Consulte los registros del servidor para obtener más información).

 

Cause

Varios escenarios causan este error, incluidos los siguientes:
  • Para acceder a la información de claves de producto y posteriormente configurarla para la instalación de Tableau Server, el servicio Windows y Tableau Server Administrative Controller se deben ejecutar en la cuenta de Ejecutar como servicio.
  • Se ingresó una clave no válida con una falta de ortografía o una clave de escritorio que comienza con “TC”.
  • Se activó el máximo de claves.
Solución

Opción 1 

Consulte el Portal del cliente de Tableau y verifique que la clave de licencia ingresada no tenga un error de ortografía.  Los errores de ortografía comunes son 0 y O, S y 5, y B y 8.  La clave de licencia debe comenzar con las letras “TS”, no “TC”.

Opción 2

Si se estableció la opción Ejecutar como usuario en la cuenta predeterminada NT AUTHORITY\NetworkService, reemplace esta por una cuenta de dominio y, a continuación, active o desactive las claves de producto de Tableau. Para obtener más información, consulte Configurar operaciones de claves de producto con un proxy de reenvío.

Si se configuró una cuenta de dominio para Ejecutar como usuario, asegúrese de que esa cuenta se pueda autenticar con el proxy de reenvío. Cambie de cuenta si es necesario. Consulte Cambiar la cuenta de Ejecutar como servicio.

Opción 3

Si el problema es que se activó el máximo de claves, desactive las licencias en una instalación que supere la capacidad permitida, según se define en nuestro EULA.

 

 

 

Recursos adicionales
Es posible que se incluya el siguiente mensaje en el registro.

Ejemplo:
ziplogs\tabadmincontroller_0.20213.21.1112.143413223401664649809205\logs\tabadmincontroller_node1-0.log
2021-12-13 17:44:42.905 +0900  qtp1152429864-1433 : INFO  com.tableausoftware.tabadmin.webapp.impl.ProductKeyService - Activating license
2021-12-13 17:44:42.905 +0900  qtp1152429864-1433 : DEBUG com.tableausoftware.domain.licensing.InitializeNativeThreadSupplier - Inicializando subproceso de comprobador en primer plano
...
2021-12-13 17:45:33.578 +0900  qtp1152429864-1433 : ERROR com.tableausoftware.tabadmin.webapp.GlobalExceptionHandler - TableauException
com.tableausoftware.license.dll.TableauException: Operation timed out.


ziplogs\tabadmincontroller_0.20213.21.1112.143413223401664649809205\logs\nativeapi_tabadmincontroller_node1-0_2021_12_13_00_00_00.txt
{"ts":"2021-12-13T17:44:42.920","pid":10872,"tid":"3788","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"InitializeForegroundThread: 6de76dec5c828a40"}
{"ts":"2021-12-13T17:44:42.920","pid":10872,"tid":"3788","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"BEGIN Verifier::Activate for SerialNumber TSXX-XXXX-XXXX-XXXX-XXXX"}
...
{"ts":"2021-12-13T17:45:33.578","pid":10872,"tid":"3010","sev":"warn","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"Request for 'https://atr.licensing.tableau.com:443/server/getAtrForServer' failed."}

 
Para obtener más información, consulte:
Número del artículo de conocimiento

001534723

 
Cargando
Salesforce Help | Article