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Tableau Server Logs Drastically Increased Disk Space After Upgrade to 2022.1 or Newer

Data pubblicazione: Dec 23, 2025
Descrizione

The Backgrounder, Vizportal, Vizqlserver, ContentExploration, Collections, and Webhooks logs could grow very large in size with regards to performance monitoring in the metrics instrumentation logs starting with 2022.1.  Specifically, the noninteractive_node.log and the instrumentations-metrics.log
 

Cause

This issue is related to three Known Issues:
  • ID 1411846 which has been partially corrected in version 2022.1.4 and newer (backgrounder only corrected).
  • W-12902788 has a solution scheduled for the Vizportal (Application Server) logs.  Check the Salesforce Known Issues website for status.
  • W-13626778 has a solution scheduled for the ContentExploration, Collections, Webhooks, and Vizqlserver logs. Check the Salesforce Known Issues website for status.
Risoluzione
Configure the appropriate keys to stop logging: 

tsm configuration set -k process.instrumentation.jmx.logging.enabled -v false --force-keys
For example: 
tsm configuration set -k vizportal.instrumentation.jmx.logging.enabled -v false --force-keys

tsm configuration set -k contentexploration.instrumentation.jmx.logging.enabled -v false --force-keys

tsm configuration set -k collections.instrumentation.jmx.logging.enabled -v false --force-keys

tsm configuration set -k webhooks.instrumentation.jmx.logging.enabled -v false --force-keys

tsm configuration set -k vizqlserver.instrumentation.jmx.logging.enabled -v false --force-keys

tsm pending-changes apply

to commit the change (requires Tableau Server restart)
 
Risorse aggiuntive
Tableau Known Issues
Numero articolo Knowledge

001534915

 
Caricamento
Salesforce Help | Article