Loading

Tableau Server retiró la licencia de manera inesperada en Linux cuando no se usa la activación ATR

Fecha de publicación: Jun 28, 2023
Descripción
Tableau Server puede quedarse sin licencia de manera inesperada cuando no se instala con el servicio de activación de ATR, sino que se usa el método de activación heredado de Flexera.  El estado sin licencia puede ocurrir aleatoriamente o cuando se reinicia la VM o el hardware.  El error suele aparecer en los registros de la siguiente manera:

tablicsvr.log:
Tableau Vendor exited DUE TO SIGNAL 36 Exit reason 4
(tableau) No features to serve, exiting
(tableau) EXITING DUE TO SIGNAL 36 Exit reason 4
(lmgrd) tableau exited with status 36 (No features to serve)

 

Cause

 Este comportamiento está relacionado con un Problema conocido en el que la información y el estado se encuentran disponibles en la página Problemas conocidos de Salesforce.
Solución

Opción 1

Actualice a Tableau Server 2023.1.3, 2022.3.7, 2022.1.15 o versiones posteriores.


Opción 2

Opción 3

Repare el almacenamiento de datos de la licencia, si corresponde:

  1. Ejecute lo siguiente desde la línea de comandos para ver los datos de la licencia de la siguiente manera:
    serveractutil -view > license_data.txt

    En algunos casos, el comando se bloquea o no produce ningún resultado; si es así, omita esta opción.
     
  2. Revise si hay cumplimiento que no funcione con el siguiente texto:
    Trust Flags: **BROKEN** RESTORE (Marcas de confianza: **NO FUNCIONAN** RESTAURAR)
     Fulfillment Type: PUBLISHER ACTIVATION (Tipo de cumplimiento: ACTIVACIÓN DEL PUBLICADOR)
     
  3. Repare los cumplimientos que no funcionen; para ello, ejecute el comando para cada FID (fullfillmentID):
    serveractutil -repair <fulfillmentID>
Recursos adicionales
Activar Tableau Server con el servicio Authorization-To-Run (ATR)
 

Para comprobar si se seleccionó el método de activación de ATR durante la instalación, ejecute el siguiente comando:

tsm config get -k serverauthorizationtorun.enabled









Número del artículo de conocimiento

001534978

 
Cargando
Salesforce Help | Article