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Non-System Administrators Cannot Add Users to Public Groups via User Territory Records in Salesforce Field Service

게시 일자: May 5, 2026
상세 설명

In Salesforce Field Service (SFS), when a non-system administrator creates a User Territory record, the system should automatically add that user to the public group associated with the service territory. However, if the non-admin user lacks the necessary 'Field Service Admin Permissions' (which includes 'View All Users' and 'Manage Users' system permissions), the auto-addition to the public group does not occur.

솔루션

Root Cause

Non-admin users creating User Territory records do not have the necessary permission set to trigger the automatic public group addition. Only users with the 'Field Service Admin Permissions' permission set — which includes 'View All Users' and 'Manage Users' system permissions — can successfully create User Territory records that result in automatic public group membership.

 

Resolution

Ensure that any user creating User Territory records has the 'Field Service Admin Permissions' permission set assigned. This permission set is required as documented in the Field Service Sharing Settings. We do not support the creation of User Territories by other personas.

Knowledge 기사 번호

004517699

 
로드 중
Salesforce Help | Article