問題:
一部のユーザーで、Salesforce Platform 内で自分のファイルにアクセスしようとした時に、予期しない動作が発生する可能性があります。これには、UI (ユーザーインターフェイス) を使用したファイルのアップロードの問題、REST APIを使用したファイルへのアクセスの問題、Apexコードを使用したファイル アクセスの問題など、さまざまな可能性があります。具体的には、アップロードしたファイルやアクセス権があるはずのファイルが見つからない場合があります。
現象:
ユーザーが自分でアップロードしたファイルを検索できない。
Apex コードを使用すると、ファイルアクセスの問題が発生する。
UI を使用してアップロードすると、ファイルアクセスの問題が発生する。
REST API を使用してファイルにアクセスすると、ファイルアクセスの問題が発生する。
原因:
この問題は多くの場合、「禁止されていないファイルをクエリ」ユーザー権限と関連する組織レベルの設定に関連しています。ユーザーに対して「禁止されていないファイルをクエリ」権限が有効になっており、組織設定の「Data Cloud へのファイルの取り込みを有効化」も有効になっている場合、システムによりフィルターが適用されます。このフィルターは、ファイル検索結果を公開として指定したファイルのみに制限します。
これらの設定は特定のシステムインテグレーションを対象としており、通常のユーザーアカウントで使用するようには設計されていません。「禁止されていないファイルをクエリ」権限は、Data Cloud へのデータの取り込みを処理するマシン間 (M2M) インテグレーション専用です。システム管理者を含め、個々のユーザーを対象としていません。
解決策:
この問題を解決するには、影響を受けるユーザー (管理者を含む) に対する「禁止されていないファイルをクエリ」ユーザー権限を無効にします。この権限は、通常のユーザーによるファイルアクセスには必要ありません。この権限は、データを Data Cloud に取り込むように設計されている特定のインテグレーションユーザーに対してのみ有効にしてください。一般ユーザーに対してこの権限を無効にすると、標準のファイルアクセス動作が回復し、ユーザーは期待どおりにファイルにアクセスできるようになります。
重要ポイント:
「禁止されていないファイルをクエリ」権限はシステムインテグレーション専用の設定であるため、一般ユーザーアカウントでは有効にしないでください。ユーザーに対してこの権限を有効にすると、意図せずにファイルへのアクセスが制限される可能性があります。
解決方法:
[設定] でユーザーの詳細ページに移動し、[概要を表示] をクリックします。
[ユーザー権限] タブに移動し、「禁止されていないファイルをクエリ」を検索します。
この権限が有効になっている場合は、検索結果に表示されます。権限の横にあるアクションボタン (三角印) をクリックし、[アクセス権付与者] を選択します。権限を付与するプロファイルまたは権限セットが表示されます。
特定されたプロファイルまたは権限セットを編集して、「禁止されていないファイルをクエリ」権限を無効にします。
追加情報:
[Data Cloud へのファイルの取り込みを有効化] 設定は、[設定] | [Salesforce Files] | [一般設定] にあります。この設定をユーザー権限と共に使用すると、ファイルの表示制限がトリガーされます。
「禁止されていないファイルをクエリ」権限がユーザーに割り当てられ、[Data Cloudへのファイルの取り込みを有効化] 設定が有効になっている場合、「すべてのデータの参照」および「すべてのファイルをクエリ」権限を持つユーザーは Lightning UI でファイルにアクセスできなくなります。ただし、Classic UI に切り替えると、レコードを開くことができます。
また、ファイルをクエリするときにレコードは返されません。
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