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Email Messages Not Visible to Community Users in Record Feed

Veröffentlichungsdatum: May 29, 2025
Beschreibung

Root Cause:

Salesforce controls visibility of EmailMessage records for external (Community) users through the IsExternallyVisible flag.

  • If IsExternallyVisible = false, external users cannot view the email in the feed.
  • This setting is designed to protect internal communication by default.
Lösung

You need to set the IsExternallyVisible flag to true on the relevant EmailMessage records to make them accessible in the community feed.

This can be done either via Anonymous Apex execution in the Developer Console or by writing an Apex Trigger to set it automatically.

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Option 1: Fix via Anonymous Apex for existing records

Use this if you want to manually make existing emails visible.

List<EmailMessage> lstEmt = [

    SELECT Id, IsExternallyVisible 

    FROM EmailMessage 

    WHERE RelatedToId = 'RECORD_ID_HERE'

];

 

for (EmailMessage emt : lstEmt) {

    emt.IsExternallyVisible = true;

}

update lstEmt;

Replace 'RECORD_ID_HERE' with the actual Contact or Object record ID.

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Option 2: Write a trigger using the above code snippet

Nummer des Knowledge-Artikels

004867920

 
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Salesforce Help | Article