Loading

レコードフィードのコミュニティユーザーにメールメッセージが表示されない

公開日: May 29, 2025
説明

根本原因:

Salesforce は、IsExternallyVisible フラグを介して外部 (コミュニティ) ユーザーの EmailMessage レコードの表示をコントロールします。

  • IsExternallyVisible = false の場合、フィードのメールは外部ユーザーに表示されません
  • この設定は、内部通信を保護するためにデフォルトで設計されています。
解決策

コミュニティフィードでアクセスできるようにするには、関連する EmailMessage レコードのIsExternallyVisible フラグを true に設定する必要があります。

これは、Developer Console の匿名 Apex 実行で、または Apex トリガーを作成して自動的に設定することで実行できます。

-----------------------------------------------------------------------------------------

オプション 1: 既存のレコードに対する匿名 Apex を介した修正

既存のメールを手動で表示する場合はこの方法を使用します。

List<EmailMessage> lstEmt = [

    SELECT Id, IsExternallyVisible 

    FROM EmailMessage 

    WHERE RelatedToId = 'RECORD_ID_HERE'

];

 

for (EmailMessage emt : lstEmt) {

    emt.IsExternallyVisible = true;

}

update lstEmt;

RECORD_ID_HERE」を実際の連絡先またはオブジェクトレコード ID に置き換えます。

------------------------------------------------------------------------------------

オプション 2: 上記のコードスニペットを使用してトリガーを作成

ナレッジ記事番号

004867920

 
読み込み中
Salesforce Help | Article