Loading

Community Users Unable to See Files on Records – How to Make Files Visible in Experience Cloud

Udgivelsesdato: Jul 7, 2025
Beskrivelse

Community (Experience Cloud) users cannot see files (uploaded as ContentDocumentLink) related to records they have access to, unless the "Customer Access" setting is enabled for those files.

Root Cause: 
Salesforce Files require manual toggling of the Customer Access setting for each uploaded file. There's currently no out-of-the-box setting to enable this by default for new or existing files.
This is a known limitation confirmed in the following Salesforce IdeaExchange posts:Clarification: Related IdeaExchange Post:
 Option to set Customer Access on Files by Default 


This link leads to a Salesforce IdeaExchange post, where customers have requested Salesforce to add the ability to set Customer Access = ON by default when files are shared to a record.
This is an IdeaExchange post, not an active feature.

  • Not supported natively
  • No admin setting exists
  • Requires custom solution (trigger/API)
Løsning

Apex Trigger for New Filesfor example:trigger SetFileVisibility on ContentDocumentLink (before insert) {
  for (ContentDocumentLink cdl : Trigger.new) {
    cdl.Visibility = 'AllUsers'; // Makes file visible to internal and external (community) users with access to the record
  }
}

Vidensartikelnummer

005101347

 
Indlæser
Salesforce Help | Article