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How to prevent Data Source Refresh Failures due to Tableau Bridge Token Expiration

Fecha de publicación: Oct 17, 2025
Descripción

Description:
In an environment using Tableau Bridge, scheduled extract refreshes may suddenly fail. This can be caused by an expired refresh token that connects Tableau Bridge and Tableau Cloud.

While the connection can be restored by signing back into the Tableau Bridge client after the token has expired, if you want to maintain the connection without any period of data refresh failures, you can renew the token before its expiration date by following the steps in this article.

 

Cause:
For security purposes, the refresh token that Tableau Bridge uses to authenticate with Tableau Cloud has a 180-day expiration period. If the token is not renewed within this period by re-signing in, it will expire, causing authentication to fail.

Solución

To avoid interruption of your scheduled data source refreshes, proactively renew the refresh token before it expires by re-signing in to the Tableau Bridge client with the following steps.

Part 1: Re-sign in to the Tableau Bridge Client

  1. On the PC running the Tableau Bridge client, right-click the Tableau Bridge icon in the Windows system tray and select Unlink. This will sign you out of the current session.

  2. Click OK on the confirmation pop-up.

  3. Click the Tableau Bridge icon in the system tray again to open the sign-in window.

  4. Sign in to Tableau Cloud using the credentials of a user with Site Administrator permissions.

  5. After signing in, confirm that the Status changes to Connected.

 

Part 2: Reconfigure the Pool in Tableau Cloud

Re-linking the Tableau Bridge client resets previous pool settings, which must be reconfigured.

  1. Sign in to Tableau Cloud as a Site Administrator.

  2. Navigate to Settings > Bridge tab.

  3. In the Default Pool section, you will see the reconnected Bridge client. Click the edit icon (pencil) to the right of the client information.

  4. In the Assign Client to Pool dialog box, select the desired existing pool from the dropdown menu to assign the client and click Save. (If a new pool is needed, create one beforehand by clicking Add New Pool.)

  5. Confirm that the client has been assigned to the target pool.

Número del artículo de conocimiento

005224350

 
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Salesforce Help | Article