Salesforce アンケートで「フローでエラーが発生しました」というエラーメールが管理者に届く場合、回答者が完了済みのアンケート(匿名でない設定)に複数タブなどで重複回答を試みた可能性があります。
Salesforce アンケートの回答が送信された際、Salesforce の管理者に以下のようなエラーメールが送信されることがあります。
件名:「(アンケート名)」フローでエラーが発生しました
本文:要求の処理中にエラーが発生しました。salesforce.com サポートチームに問題が通知されました。(中略) エラー ID: xxxxxxxxx-xxxxx (1743689836)
原因
このエラーは、仕様上の標準動作です。
匿名でない設定のアンケートにおいて、回答者が既に完了したアンケート招待に対し、再度回答を送信しようとすると発生します。
例えば、アンケート回答者が同一の招待リンクを複数のブラウザタブで同時に開き、最初のタブでアンケートを完了させた直後に、もう一方のタブから送信を試みた場合など、重複した回答の試みをシステムが検知した際に通知されるものです。
対処法
本事象が発生した場合、アンケートの回答者に対し、複数タブでアンケートを開いて操作したり、完了後に複数回の回答を試みたりしないようご案内ください。
参考情報
Salesforce アンケートは、匿名設定でない場合、同じユーザーから複数回の回答ができない設計になっています。関連情報については、Salesforce ヘルプ記事「アンケートへの招待リンクの送信」もご参照ください。
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