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[Upload Files] button is not displayed in "Notes & Attachments"

Julkaisupäivä: Nov 18, 2025
Kuvaus

In orgs with Profile-Based Chatter Rollout, if the "Enable Chatter" permission is not assigned to a user, the [Upload Files] button will not appear (e.g., in "Notes & Attachments"). This is because Salesforce Files is also disabled.

Ratkaisu

Cause
In organizations where the profile-based Chatter rollout is enabled, disabling the "Enable Chatter" permission for a user also disables their access to Salesforce Files. As a result, the user cannot use Salesforce Files functionality, affecting the "Notes & Attachments" and "Files" related lists as follows:

・"Notes & Attachments" related list: The [Upload Files] button is not displayed.
・"Files" related list: The related list is not displayed.

 

Solution
To allow the user to utilize the file upload functionality (Salesforce Files), enable the permission using the following steps:

1. Identify the Profile or Permission Set applied to the user.
2. In the permission settings for that Profile or Permission Set, enable "Enable Chatter".

 

Important Considerations
Enabling this setting will allow all users with this Profile or Permission Set to use Salesforce Files, but it will also enable Chatter functionality.

Knowledge-artikkelin numero

005228865

 
Ladataan
Salesforce Help | Article