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Agentforce : Update Record Action was Automatically Added to Agent

Date de publication: Dec 15, 2025
Description

This article explains an issue where the "Update Record" action was automatically added to the General CRM topic for agents in Agentforce.

The "Update Record" action was unexpectedly added to the General CRM topic for agents in Agentforce. This article provides details on the cause and steps to resolve the issue.

Cause : 

The "Update Record" action was made Generally Available (GA) around February 25. At that time, it was included as part of the Out-of-the-Box (OOTB) Standard Topic, General CRM. Since the concept of Local Assets did not exist at that time, any new action added to a topic as part of a feature update was automatically applied to all agents using that topic. As a result, the "Update Record" action was automatically added to the General CRM topic.

Résolution

To address this issue, the concept of Local Assets was introduced. Local Assets allow agents to create a local copy of topics and their configurations, ensuring that global changes do not impact an agent's topic configuration.

Follow these steps to resolve the issue and create Local Assets:

  1. If the agent is already activated, deactivate it.
  2. Create a new version of the topic and click Save. This will generate Local Assets for your agent.
  3. If you do not want the "Update Record" action, remove it from the topic configuration.
Ressources supplémentaires

 

Numéro d’article de la base de connaissances

005232883

 
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Salesforce Help | Article