Loading

Emails are delayed or experience temporary failures with messages like "no mail servers for this domain could be reached at this time".

Date de publication: Sep 22, 2026
Description

This error "no mail servers for this domain could be reached at this time" often indicates that the Salesforce Mail Transfer Agent (MTA) cannot correctly resolve the recipient's domain, or can resolve the domain but recipient's MTA is not responding. 

Résolution

This article explains how to troubleshoot the "no mail servers for this domain could be reached at this time" error, and what to expect while it resolves.

How to Fix This

Collaborate with your Network Team to ensure your DNS records are correctly configured and reachable. If using Email Relay, consider disabling "Enable compliance with standard email security mechanisms" and "Activate Bounce Management" as they could affect delivery to your relay host due to the inclusion of a Salesforce return path in the headers of the email that is not aligned with your own domain.

Good to Know

Note: Salesforce does not have an SLA on email sending times, as due to SMTP errors like the above receiving MTAs could become available during our default retry period of 24 hours. These transient delivery issues often clear on their own as they are related to factors beyond the control of Salesforce such as DNS issues, load or throttling by the receiving MTA or ESP (Email Service Provider), firewall changes at the receiving end, and other Internet challenges related to SMTP mail delivery.

Numéro d’article de la base de connaissances

005305553

 
Chargement
Salesforce Help | Article