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Tableau Desktop on Mac Not Recognizing the Amazon Redshift ODBC 2.x Driver

게시 일자: Apr 20, 2026
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Environment

  • Tableau Desktop

  • macOS (Apple Silicon and Intel)

  • Amazon Redshift

  • Amazon Redshift ODBC Driver version 2.x

Issue

After downloading and installing the Amazon Redshift ODBC 2.x driver package on macOS, Tableau Desktop continues to display the following error message when attempting to connect to Amazon Redshift:

"To use this connector, you need to download and install the driver first."

Additionally, the newly installed driver may not be visible in third-party ODBC Manager applications.

Cause

The Amazon Redshift .pkg installer placed the driver files on the Mac's hard drive successfully, but the installer script failed to append the driver's configuration block to the system's odbcinst.ini file. Because Tableau relies on this .ini file as a directory to locate physical driver files, it cannot detect the driver until the entry is manually added.

솔루션

To resolve this issue, you must manually register the driver by adding its configuration details to your Mac's odbcinst.ini file using the macOS Terminal. By default, this file is located at /Library/ODBC/odbcinst.ini.

  1. Open Finder and navigate to Applications > Utilities > Terminal.

  2. In the Terminal, open the configuration file using the nano text editor and sudo privileges by running the following command: sudo nano /Library/ODBC/odbcinst.ini

  3. Enter your Mac administrator password when prompted.

  4. Use the arrow keys to scroll to the bottom of the file. Copy and paste the following text block exactly as written:

[ODBC Drivers]
Amazon Redshift ODBC Driver (x64)=Installed

[Amazon Redshift ODBC Driver (x64)]
Description=Amazon Redshift ODBC Driver
Driver=/opt/amazon/redshiftodbcx64/librsodbc64.dylib

  1. Save the file by pressing Control + O, then press Return to confirm the file name.

  2. Exit the text editor by pressing Control + X.

  3. Completely close Tableau Desktop if it is currently open.

  4. Re-launch Tableau Desktop and attempt the connection to Amazon Redshift again.

추가 자원

To verify that the physical .dylib driver file actually exists on your machine before editing the file, you can run the following command in Terminal:

ls -l /opt/amazon/redshiftodbcx64/librsodbc64.dylib

https://docs.aws.amazon.com/redshift/latest/mgmt/odbc-driver-configure-mac.html

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