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LWC Toolkit API and Einstein Next Best Action Not Supported with Agentforce Contact Center (AFCC)

Publish Date: Apr 23, 2026
Description
Issue 1: Lightning Web Component (LWC) Toolkit API Not Working with Agentforce Contact Center Softphone
 
Description
The Salesforce Voice (formerly Service Cloud Voice) LWC Toolkit API is currently not supported with the Agentforce Contact Center (AFCC) Softphone. Call controls built using the LWC Toolkit API — including Mute/Unmute, Hold, and End Call — do not function when used with the AFCC Softphone.
Root Cause
The LWC Toolkit API relies on Enhanced Softphone Toolkit Events, which are not available in the current release for AFCC. This has been confirmed as a known product limitation (not a bug).
 
Issue 2: Einstein Next Best Action Not Triggering in Agentforce Contact Center
Description
The Einstein Next Best Action (NBA) component does not trigger for agents using the Agentforce Contact Center. This is a known limitation of the current AFCC implementation.
Resolution

Support for Enhanced Softphone Toolkit Events with AFCC is targeted for Summer '26 (Version 262). Until then, customers using AFCC will not be able to use LWC Toolkit API call controls.

Knowledge Article Number

005318957

 
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Salesforce Help | Article