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アカウント名にアンダースコアが含まれていると CRM Analytics で Snowflake に接続できない

公開日: May 11, 2026
説明

CRM Analytics の Snowflake 接続は次のエラーで失敗します。

Error:HTTP Invalid HTTP response from null:443!Cannot conclude ssl handshake.Cause:Server not trusted by the user.Error in Job ID connector..

  •  Snowflake 側で必要な Salesforce IP アドレスをすべてホワイトリストに登録しても、エラーは解消されません。
  • この問題はデータ同期中、または CRMA データマネージャーでの Snowflake 接続の検証中に発生します。


原因 :

Snowflake アカウント名にアンダースコア (_) が含まれていると、CRM Analytics は Snowflake への安全な接続を確立できません。これは、インターネット標準 RFC 2396 (有効な URI/URL 形式を定めた規格) で定義されているように、Web アドレスで使用されるアンダースコアが有効な文字とみなされないためです。セキュアな接続で使用するホスト名はこの標準に従う必要があるため、アンダースコアのあるアカウント名は無効とされ、セキュアな接続 (SSL) が失敗します。
つまりインターネット標準によりアンダースコアは Web アドレスに使用できず、Snowflake アカウント名は接続 URL の一部として使用されるため、アンダースコアがある場合、接続を安全に確立できません。

解決策

Snowflake コネクタで、Snowflake アカウント名のアンダースコア (_) をハイフン (-) に置き換えて更新してください。

ステップ

1. [設定] → [分析] → [データマネージャー] → [接続] の順に移動します。
2. 既存の Snowflake 接続を見つけて編集します。
3. [アカウント名] 項目で、すべてのアンダースコアをハイフンに置き換えます。
     変更前: accountname_test
     変更後: accountname-test
4. 接続を保存し、[テスト接続] をクリックして確認します。


注意: 変更する前に、Snowflake 管理者にハイフン付きの正しいアカウント識別子を確認してください。形式は実際の Snowflake アカウント URL と一致する必要があります。

ナレッジ記事番号

005319003

 
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