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Unable to Delete or Reset User Profile Image to Default in Tableau Server or Tableau Cloud

Publish Date: May 18, 2026
Description

Users can upload a profile image in the Tableau Server or Tableau Cloud user profile settings. 
However, after an image has been set, there is no "Delete" or "Reset" option available to remove the image and return to the default placeholder (the silhouette or initials). 

Cause:

This behavior is due to current product design. The functionality to completely remove a profile image and restore the default state is not currently implemented.

Resolution

Since there is no direct "Delete" button, please use the following workaround to overwrite the current image:

1. Prepare an alternative image file that resembles the default state (e.g., a plain background or a generic silhouette image). 
2. Log in to Tableau Server or Tableau Cloud and navigate to [My Account Settings] by clicking your user icon in the top-right corner. 
3. In the profile image section, click on the profile image.
4. Select the new image file prepared in Step 1 and upload it to overwrite the existing profile image.

Note: There is no Tableau REST API endpoint to delete or reset a user profile image. The only available method is to replace it by uploading a new image via My Account Settings.

Additional Resources

For information on how user icons are displayed when using non-Latin characters: Customize User Icons for Non-Latin Display Names

Knowledge Article Number

005347763

 
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Salesforce Help | Article