Loading
Feature Degradation | Agentforce Voice Read More

Deployment Error: "Cannot use field:WhatId in RelatedContent Section. Entities with issues: [...]"

Publish Date: May 19, 2026
Description

When deploying a Page Layout to your org, you might encounter a deployment error, 'Cannot use field: WhatId in RelatedContent section'. If the "Entities with issues: [...]" listed in the error message begin with the namespace prefix of a managed package, follow these steps to confirm the error is related to an expired managed package. Then, use the workarounds and long-term solutions to resolve the error. 

 

Troubleshooting Steps

  1. Check the status of the managed package.
    1. Navigate to Setup | Installed Packages. 
    2. Search for the namespace prefix that appears in the error message. 
    3. If the package is "Expired", use the workarounds and long-term solutions provided below.
  2.  If applicable, test the deployment in another environment where the managed package has a "Free" or unexpired status. 
    1. If the deployment is successful in the second org but fails in the original org, use the workarounds and long-term solutions provided below.
  3. If your managed package is not expired and the workarounds do not resolve your error, submit a case with Support. 
Resolution

Root Cause

When deploying a package that includes the Activity CustomObject, a deployment validation checks for the WhatId on entities with Track Activities enabled. If entities within that managed package have Track Activities enabled and the managed package is expired, then we will no longer have API-level access to those entities, so the validation will fail. 

 

Workarounds

  1. Remove the WhatId field from relatedContentItems in the layout XML before deploying, then re-add it manually via the Setup UI after deployment completes. 
  2. Split the deployment into two parts: deploy the layout file separately from other metadata, specifically the Activity CustomObject, to avoid validation issues.

 

Long-Term Solutions

  1. Work with your managed package provide to renew your expired package.
  2. Remove the expired package from the org if it's no longer needed. 
Knowledge Article Number

005384603

 
Loading
Salesforce Help | Article