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カスタムシステム管理者プロファイルを使用すると、FSL 管理パッケージのインストールが列の欠落および未定義項目エラーで失敗する

公開日: Jun 30, 2026
説明

現象/エラーメッセージ

FSL 管理パッケージのインストールが失敗したときの通知メールには次のエラーが表示されます。
ダッシュボードエラー (列の欠落):

  • Dashboard(FieldServiceWorkCapacityDashboards/CompareAggregatedWorkstreamUtilizationV2):WorkCapacityUsage$ServiceTerritory column is missing
  • Dashboard(FieldServiceWorkCapacityDashboards/RRYSGLHrmcRLDBGKUxngyrueoGIwXW1):WorkCapacityUsage$ServiceTerritory column is missing
  • Dashboard(FieldServiceWorkCapacityDashboards/WeeklyAggregatedWorkstreamUtilizationV2):WorkCapacityUsage$ServiceTerritory column is missing
  • Dashboard(FieldServiceWorkCapacityDashboards/vwfpkAEnvconLBZYbbJkPTWzLlVfrb):WorkCapacityUsage$ServiceTerritory column is missing

LightningComponentBundle 検証エラー:

  • markup://FSL:dispatchConsoleMetadataProcessor:Validation error (FieldUndefined@[uiapi/query/UserSetting__c/edges/node/FSL__User_Setting_Territory_UserSettings__r]):Field 'FSL__User_Setting_Territory_UserSettings__r' in type 'FSL__UserSetting__c' is undefined. line:28, column:37, startIndex:1329

これらのエラーは、組織でサービステリトリーが欠落しているか、設定が誤っていることを示しているわけではありません。インストールを実行したユーザーのプロファイルに必要な権限が不足し、管理パッケージのインストールが不完全に終わったことで発生するエラーです。

根本原因

FSL 管理パッケージのインストールは、カスタムシステム管理者プロファイル (通常は、標準のシステム管理者プロファイルからコピーされたプロファイル) が割り当てられているユーザーが実行します。カスタムコピーしたプロファイルは、管理パッケージのインストールに必要なすべてのシステム権限を継承するとは限りません。
この失敗は、次の 2 つの特定の権限が不足するために発生する可能性があります。

  1. 「インストールされていない接続アプリケーションを承認」システム権限の不足 - 管理パッケージのインストールを正常に完了させるには、インストールを実行するユーザーのプロファイルにこの権限が必要です。
  2. 非標準のシステム管理者プロファイル - Salesforce Field Service 管理パッケージのインストールを実行するユーザーは、標準で用意されている「システム管理者」プロファイルか、必要なすべての権限が明示的に有効化されているカスタムプロファイルを持っている必要があります。カスタムコピーしたプロファイルには、気づかないうちにこれらの権限の 1 つまたは複数が不足している可能性があります。
解決策

解決策

オプション 1: 不足しているシステム権限をカスタムプロファイルに追加する (推奨 - 中断が最も少ない)

  1. [設定] → [プロファイル] の順に移動し、該当するカスタム管理者プロファイルを選択します。
  2. [システム権限] に移動します。
  3. 有効化: ✅ インストールされていない接続アプリケーションを承認
  4. プロファイルを保存します。
  5. FSL 管理パッケージのインストールを再試行します。

注意: この権限を有効にしてもインストールが失敗する場合は、オプション 2 に進みます。

オプション 2: インストールを実行するユーザーを一時的に標準のシステム管理者プロファイルに切り替えるか、標準のシステム管理者プロファイルが割り当てられたユーザーを使用する

この解決策は実際に動作することが確認されています。

  1. [設定] → [ユーザー] の順に移動し、インストールを実行するユーザーを選択します。
  2. ユーザーのプロファイルを標準のシステム管理者プロファイルに変更するか、システム管理者プロファイルをすでに使用しているユーザーを使用します。
  3. 公式のインストールリンクを使用して FSL 管理パッケージをインストールします。
  4. インストールが正常に完了したら、ユーザーのプロファイルを元のカスタム管理者プロファイルに戻します (カスタム管理者プロファイルを使用している場合)。
その他のリソース
  • WorkCapacityUsage$ServiceTerritory 列の欠落エラーと FSL__User_Setting_Territory_UserSettings__r の未定義の項目エラーは、パッケージが正常にインストールされると自動的に解決します。ダッシュボードや項目を個別に修正する必要はありません。
  • これらのエラーは、[Field Service 設定] で作業業務量が有効になっているか無効になっているかに関係なく表示されます。
  • インストールを実行するユーザーがカスタム管理者プロファイルを使用している場合、この問題は Sandbox 環境と本番環境のどちらにも発生します。
ナレッジ記事番号

005386861

 
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