Sie befinden sich hier:
Fehlerbehebung bei Datenstromfehlern
Beim Importieren von Daten in Data 360 können bei Datenströmen verschiedene Probleme auftreten. Verwenden Sie diesen Abschnitt zur Fehlerbehebung, um häufige Fehler beim Daten-Streaming zu identifizieren und zu beheben.
Allgemeine Zero Copy-Datenstromfehler
ERROR: Time out in polling
job.Try increasing the timeout value hinzu.
ERROR: EXEC_JOB_EXEC_ERR
Zeitüberschreitungsfehler und Fehler bei der Auftragsausführung treten auf, wenn Sie das optimale Datenvolumen in Zero-Copy-Konnektoren überschreiten. Stellen Sie zum Beheben von Zeitüberschreitungsfehlern sicher, dass Ihr Datenvolumen innerhalb folgender Grenzen liegt:
- 234 GB oder 1 Milliarde Zeilen für Amazon Redshift
- 20 GB oder 750 Millionen Zeilen für Snowflake
- 23 GB oder 500 Millionen Zeilen für Databricks
- 10 GB oder 100 Millionen Zeilen für Google BigQuery
Allgemeine CRM-Datenstromfehler
ERROR: Invalid extractor job query found.\"errorCode\":\"INVALID_TYPE\"
ERROR: Invalid extractor job query found.\"errorCode\":\"INVALID_FIELD\"
Ein INVALID_TYPE gibt ein Problem beim Zugriff auf das CRM-Objekt an. Ein INVALID_FIELD gibt an, dass ein Feld im Objekt gelöscht wurde oder dass der Zugriff auf ein Feld aufgrund von Berechtigungsänderungen verloren gegangen ist. Um solche Fehler zu beheben,
- Stellen Sie sicher, dass die Objekte und Felder nicht gelöscht wurden.
- Stellen Sie sicher, dass die Salesforce CRM-Berechtigungen weiterhin über die Berechtigungen "Lesen", "Alle Datensätze anzeigen" und "Alle Felder anzeigen" für das in der Ausnahme aufgeführte Objekt verfügen.
ERROR: OPERATION_TOO_LARGE
Ein OPERATION_TOO_LARGE gibt an, dass eines der Felder auf eine Einheit verweist, auf die der CRM-Konnektor keinen Zugriff hat. Wenn eine Einheit mit einer anderen Einheit verknüpft ist, überprüft Data 360, ob der zugehörige Datensatz auch Berechtigungen erteilt hat, bevor eine Zeile zurückgegeben wird. Diese zusätzliche Abfrage kann den Vorgang überlasten, da die ursprüngliche Abfrage für jede zugehörige Einheit erweitert wird. Überprüfen Sie zum Beheben dieses Problems, ob allen verwandten Objekten Lese- und Anzeigezugriff gewährt wird.
Allgemeine SFTP-Datenstromfehler
ERROR: STREAM_JOB_STATUS_FAILURE
Ein STREAM_JOB_STATUS_FAILURE kann auf eine zu große Dateigröße zurückzuführen sein. Bei Secure File Transfer Protocol (SFTP) beträgt die Obergrenze für eine Ausführung insgesamt 4,5 GB und jede einzelne Datei 500 MB. Stellen Sie zum Beheben von Dateigrößenproblemen sicher, dass die Dateigrößen im SFTP innerhalb der in den Data 360-Obergrenzen und -Richtlinien beschriebenen Grenzen liegen.
ERROR: STREAM_JOB_STATUS_CANCELLED
Ein STREAM_JOB_STATUS_CANCELLED tritt auf, wenn zwei aufeinanderfolgende Aufträge für denselben Datenstrom ausgeführt werden. Stellen Sie sicher, dass Sie jeweils nur einen Auftrag in einem Datenstrom ausführen.
ERROR: STREAM_JOB_STATUS_FAILURE – Protokoll zeigt "Lesbare Daten haben eine andere Länge als erwartet"
Dieser Fehler liegt daran, dass SFTP-Konnektoren nicht mehrere Dateien in einer ZIP-Datei unterstützen. Führen Sie zum Beheben dieses Problems alle Dateien zusammen oder nehmen Sie den entpackten Ordner mithilfe eines Platzhalters auf.
ERROR: Unknown Error
Ein Unknown
Error tritt in der Regel auf, wenn die Datei, die Sie verwenden möchten, beschädigt ist. Versuchen Sie es erneut mit einer anderen Datei.
ERROR: Job Aborted Due to Stage Failure
Wenn die Quelldatei fehlt, tritt ein Job Aborted Due to Stage Failure auf.
ERROR: Unable to position the current position from -1 to
0
Dieser Fehler tritt aufgrund gleichzeitiger Verbindungsobergrenzen auf Ihrem SFTP-Server auf. Wenn mehrere Datenströme gleichzeitig geplant werden, können sie alle versuchen, gleichzeitig eine Verbindung herzustellen, was zu einem Fehler führt. Lösen dieses Problems:
- Überprüfen Sie die Obergrenze für gleichzeitige Verbindungen auf dem SFTP-Server.
- Stellen Sie sicher, dass die Anzahl der Datenströme, die dieselbe Verbindung verwenden, die Obergrenze für gleichzeitige Verbindungen nicht überschreitet. Staffeln Sie die Planung von Datenströmen um etwa 30 Minuten, um Konflikte zu vermeiden.
