Loading
Call center
Termini della verifica utente

Termini della verifica utente

Per impostare la verifica utente è necessario avere dimestichezza con token, chiavi e insiemi di chiavi. Questi termini descrivono i concetti principali associati a questa funzione. Per maggiori dettagli, questo articolo descrive i termini da comprendere.

Versioni (Edition) richieste

Visualizzare le versioni supportate.
Segno di spunta Questo articolo si applica a: Canali Chat in app ottimizzata e Chat Web ottimizzata
Icona X Questo articolo non si applica a: WhatsApp ottimizzato, Facebook Messenger ottimizzato, SMS standard e ottimizzato, Apple Messages for Business ottimizzato, LINEA ottimizzata e Porta il tuo canale

JSON (JavaScript Object Notation)

Che cos'è?

JSON è un formato di dati open-standard che utilizza una sintassi semplice e leggibile per archiviare e trasferire i dati. Anche se il nome contiene "JavaScript", il formato è indipendente dal linguaggio. Il concetto di base è un elemento costituito da una chiave, seguita da due punti (:), seguita da un valore. È possibile creare elementi per stringhe, numeri e valori booleani. È anche possibile creare un elenco di elementi separati da virgole oppure nidificare gli elementi all'interno degli elementi creando degli oggetti.

Per ulteriori informazioni, vedere RFC 8259.

Come si utilizza per la chat ottimizzata?

I nostri token e chiavi vengono memorizzati utilizzando JSON.

Esempio

Ecco un esempio di JSON.

{
  "name": "Carrie",
  "age": 135, 
  "isHappy": true,
  "favorite_colors": ["blue", "green", "yellow"],
  "catch_phrase": "I can’t believe I’m 135 years old!"
}

Token Web JSON (JWT, JSON Web Token)

Che cos'è?

Un JWT è un metodo compatto e indipendente per passare le informazioni tra due parti. I dati in un JWT vengono memorizzati come oggetto JSON. Spesso viene firmato in modo digitale per consentire al destinatario di verificare l'integrità dei dati. Un JWT è in genere codificato per proteggere gli URL in fase di trasmissione.

Un JWT è costituito da tre parti: un'intestazione, un payload e una firma. L'intestazione contiene le informazioni relative al modo in cui viene firmato il token. Il payload contiene informazioni sull'utente e altri dati. La firma contiene il risultato firmato dell'intestazione, il payload e il segreto. La firma non crittografa i dati, ma garantisce che i dati non vengano alterati.

Per ulteriori informazioni, vedere RFC 7519.

Come si utilizza per la chat ottimizzata?

Un JWT garantisce la visualizzazione della cronologia delle conversazioni corretta per l'utente appropriato. Dopo aver verificato che il token è valido, si utilizza l'oggetto del token, la proprietà "sub", per identificare l'utente e visualizzarne la cronologia delle conversazioni. Il valore "sub" nel JWT viene memorizzato come parte del campo Chiave piattaforma messaggistica del record Utente finale messaggistica. Ad esempio, se il valore "sub" è user-123, la chiave piattaforma di messaggistica potrebbe essere v2/iamessage/AUTH/{auth_id_info}/uid:user-123.

Esempio

Questo JSON è un'intestazione di esempio.

{
  "kid": "123456",
  "typ": "JWT",
  "alg": "RS256"
}

Questo JSON è un esempio di payload.

{
  "sub": "user-123",
  "iss": "example.com",
  "exp": 1674164345,
  "iat": 1674158345
}

Quando un JWT è firmato e codificato, ha il seguente formato:

hhhhhhh.ppppppp.sssssss

Dove hhhhhhh rappresenta l'intestazione, ppppppp rappresenta il payload e sssssss rappresenta la firma.

Questi dati rappresentano un esempio di JWT codificato.

eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.
eyJzdWIiOiIxMjM0NTY3ODkwIiwibmFtZSI6IkpvaG4gRG9lIiwiaWF0IjoxNTE2MjM5MDIyfQ.
SflKxwRJSMeKKF2QT4fwpMeJf36POk6yJV_adQssw5c

È possibile utilizzare un sito come JWT.io per decodificare un JWT codificato.

Avvertenza
Avvertenza Non condividere i JWT di produzione con altre organizzazioni e non incollare i JWT di produzione in siti o strumenti.

Chiave Web JSON (JWK) e insieme di chiavi Web JSON (JWKS)

Che cos'è?

Un JWK rappresenta una chiave di crittografia pubblica che può essere utilizzata per verificare la validità di un token (per la verifica utente, questo token è un token Web JSON). Un insieme di chiavi JWK è chiamato anche JWKS (JSON Web Key Set).

Per ulteriori informazioni, vedere RFC 7517.

Come si utilizza per la chat ottimizzata?

Per verificare la validità del token Web JSON (JWT), si utilizza un insieme di chiavi Web JSON (JWKS). In questo modo si garantisce che un token non alterato sia stato inviato dall'origine corretta. È richiesta una lunghezza minima di 2048 bit della chiave RSA.

Esempio

{
  "kid":"123456",
  "alg":"RS256",
  "use":"sig",
  "kty":"RSA",
  "x5c":["<Your public certificate>"],
  "y":"y",
  "n":"<Base64-encoded modulus>",
  "e":"<Base64-encoded public exponent>",
  "crv":"crv",
  "d":"d",
  "k":"k"
}
 
Caricamento
Salesforce Help | Article