Print this page

SAML Validation Error "The specified portal is not enabled for login through this site"

Knowledge Article Number 000199454
Description
Customer is trying to setup Single_Sign_On to log into salesforce, he receives below error 
 
 "Your login attempt using single sign-on with an identity provider certificate has failed. Please contact your salesforce.com administrator for more information"
 
When validated the SAML response using SAML validator, customer received the following result with the error as 

 
12. Checking that the Site URL Attribute contains a valid site url, if provided 
The specified portal is not enabled for login through this site 

=================================================================
SAML Validator  Results
Last recorded SAML login failure: xxxxxxxxxxxxxxxxxxxxxx
Unexpected Exceptions 
Ok 
1. Validating the Status 
Ok 
2. Looking for an Authentication Statement 
Ok 
3. Looking for a Conditions statement 
Ok 
4. Checking that the timestamps in the assertion are valid 
Ok 
5. Checking that the Attribute namespace matches, if provided 
Not Provided 
6. Miscellaneous format confirmations 
Ok 
7. Confirming Issuer matches 
Ok 
8. Confirming a Subject Confirmation was provided and contains valid timestamps 
Ok 
9. Checking that the Audience matches 
Ok 
10. Checking the Recipient 
Ok 
Organization Id that we expected: xxxxxxxxxxxxxxxxxxx 
Organization Id that we found based on your assertion: xxxxxxxxxxxxxxx 
11. Validating the Signature 
Is the response signed? true 
Is the assertion signed? false 
Is the correct certificate supplied in the keyinfo? true 
Ok 
12. Checking that the Site URL Attribute contains a valid site url, if provided 
The specified portal is not enabled for login through this site
13. Looking for portal and organization id, if provided 
Found portal_id attribute: xxxxxxxxxxxxxx
Found organization_id attribute: xxxxxxxxxxxxxx 
14. Checking if session security level is valid, if provided 
Ok

================================================
Resolution
When customer tries to login into domain with login settings, having  the option as " Login- Not Allowed" it throws the  specific error

"The specified portal is not enabled for login through this site"
 
In order to solve the error go to  Setup-->Develop-->Sites 
 
Click on the Site Label and then click on the button "Login Settings"  button at the top and select one of the available options from drop down for "Enable Login For"




Attachments
Name Type Size
LoginSetting.png
14KB

promote demote